ruby nokogiri ubuntu

HTMLを解析するためのライブラリNokogiriが入らない!

gem install nokogiri

でインストールできるはずなんだけど、どうもlibxml2-develとlibxslt-develが足りないようだ。

それを入れようと思ったが、ubuntuだと

  • libxml2-develは
    libxml2-dev
  • libxslt-develは
    libxslt1-dev
    のようだ。

名前統一しろよ〜〜〜。

sudo apt-get install libxml2-dev
sudo apt-get install libxslt1-dev
sudo gem install nokogiri

取り合えずこれで入ったので一件落着

以下ログ

 478  gem install nokogiri
 479  sudo gem install nokogiri
 480  sudo apt-get install libxml2-devel
 481  sudo apt-get install libxml2
 482  sudo apt-get install libxml2-devel
 483  sudo apt-get list
 484  sudo apt-chach search libxml2
 485  sudo apt-cache search libxml2
 486  sudo apt-cache search libxml2-dev
 487  sudo apt-get install libxml2-dev
 488  sudo gem install nokogiri
 489  sudo apt-get install libxslt-dev
 490  sudo apt-cache search libxslt-dev
 491  sudo apt-cache search libxslt
 492  sudo apt-cache search libxslt1-dev
 493  sudo apt-get install libxslt1-dev
 494  sudo gem install nokogiri

あとこんなのも問題かも

Rubygemsプラグインがホームディレクトリに入ってしまった時の対処方法(Mac) (BLOG) | RED-MOUNT.COM <http://www.red-mount.com/blogs/show/rubygems_plugin_uninstall_error>


トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2009-07-30 (木) 15:41:18 (3608d)