log

sshfs No package 'glib-2.0' found

sshfsでconfigureしたら

No package 'glib-2.0' found
No package 'gthread-2.0' found

glibを入れたが、それでもエラーが出る。

error with ./configure No package 'glib-2.0' found - Ubuntu Forums http://ubuntuforums.org/showthread.php?t=450820

によると

delib2.0 devらしい

調べたら yumではglib2-develだった

# yum install glib2-devel

でgthread-2.0を入れなくてもconfigureできた

sshfs sshfs: error while loading shared libraries: libfuse.so.2: cannot open shared object

!注意 fuseのサンプルコードをコンパイルして実行するときも、libfuseが必要!!

libfuse.so.2がない http://be.nucl.ap.titech.ac.jp/~koba/mem/sshfs.html

./configure --prefix=/usr

で解決

解決しない場合

Redhat Enterprise Linux securely mount remote Linux / UNIX directory or file system using SSHFS http://www.cyberciti.biz/tips/rhel-centos-mounting-remote-filesystem-using-sshfs.html

を参考に

# vi /etc/ld.so.conf.d/fuse.conf

fuse.confを新規作成.そのファイルに

/usr/local/lib

を追加

# ldconfig

を実行

  • libfuseの場所
    # find / -name libfuse*
    	/usr/lib/libfuse.a
    	/usr/lib/libfuse.la
    	/usr/lib/libfuse.so.2
    	/usr/lib/libfuse.so
    	/usr/lib/libfuse.so.2.8.5
    	/usr/local/lib/libfuse.a
    	/usr/local/lib/libfuse.la
    	/usr/local/lib/libfuse.so.2
    	/usr/local/lib/libfuse.so
    	/usr/local/lib/libfuse.so.2.8.5

トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2010-10-04 (月) 14:49:20 (3119d)