google app engine deploy error:The server encountered an error and could not complete your request

eclipseで開発したプロジェクトをappengineにdeployしたときに、エラーが起きた。(環境=Linux)

原因は開発環境でJAVA 1.7を使っていたのが問題だったようだ。

【Java】Google App Engineにデプロイするまでにやったこと - ? <http://blog.livedoor.jp/nec69/archives/51957829.html>

 ・Eclipseの「ウィンドウ」-「設定」-「Java」-「コンパイラー」から「コンパイラーの準拠レベル」を1.6に変更

この方法だと、1.7が入っている場合は1.6も選べるようになる。

しかし一回プロジェクトを作ったので、全体のcompiler設定を変えてもプロジェクトごとには設定が反映されない。

その場合は

Project→Propeies→Java Compiler

で1.6を選べばOK


トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2012-10-09 (火) 18:06:20 (2383d)