Ubuntu とEclipseで Tomcat バージョン 7 のインストールとテスト

結構はまった。

Ubuntu で Tomcat バージョン 7 のインストールとテスト実行 <http://www.kkaneko.com/rinkou/tomcat/ubuntutomcat.html>

このサイトの説明どおりに設定しないと、Tomcatは動くけど、Eclipse連携ができない状態になる。

1.aptでtomcat7を入れる。tomcat7-user以降はなくてもいいかも

sudo apt-get install tomcat7 tomcat7-user tomcat7-admin libtomcat7-java

2.サイトに書いてあるとおりに、configファイルをコピーする

	cd /usr/share/tomcat7; for i in /var/lib/tomcat7/*; do echo $i; sudo ln -s $i .; done
	cd /var/lib/tomcat7
	 sudo ln -s /usr/share/tomcat7/bin .
	 sudo ln -s /usr/share/tomcat7/lib .
	cd /var/lib/tomcat7/conf
	 sudo chmod 644 tomcat-users.xml
	if [ ! -f /var/lib/tomcat7/conf/catalina.policy ]; then 
	  if [ -f /var/cache/tomcat7/catalina.policy ]; then
	    cd /var/lib/tomcat7/conf
	    sudo ln -s /var/cache/tomcat7/catalina.policy
	  fi
	fi

3.tomcat7の起動を確かめる

sudo /etc/init.d/tomcat7 start

4.eclipseのインストール

一度、
sudo apt-get install eclipse

でeclipseを入れていたが、

このeclipseではなくて"Eclipse IDE for Java EE Developers" を以下からDLして使う

http://www.eclipse.org/downloads/moreinfo/jee.php

5.eclipseの設定

Eclipse を使用しての Java サーブレット・プログラム開発 <http://www.kkaneko.com/rinkou/tomcat/eclipsetomcat.html>

を参考に入れた。

tomcat7のディレクトリは

/usr/share/tomcat7

を使った。

error:Could not load the Tomcat server configuration at /Servers/Tomcat v7.0 Server at localhost-config. The configuration may be corrupt or incomplete

このメッセージにハマった。原因は

eclipseでserverを設定した時に、Tomcatが起動していたので、ちゃんとPATHが通ってなかったのが問題だったかもしれない。

その場合

一度、eclipseのserver項目を消して、再度登録すれば、うまく動いた。

その他リンク

Configure Tomcat 7 & Eclipse on Ubuntu » Xrigher <http://liuweipingblog.cn/linux/ubuntu/configure-tomcat-7-eclipse-on-ubuntu/>


トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2013-12-20 (金) 17:05:44 (2004d)