ubuntu gd install php

いきさつ

PHPエンジニア養成読本に出てたこのライブラリを試そうと思ったが、DGの読み込みでエラーになった Quick introduction — Imagine, image manipulations reloaded https://imagine.readthedocs.org/en/latest/usage/introduction.html#installation

調査

$ php5 -i | grep -Ei '^(gd|imagic|gmagic)' | grep enabled

をやってもなにも反応がなかった。 たぶんDGが入っていないのが問題

apt-getでGDインストール

PHP/UbuntuのPHP環境にGDライブラリのインストールする方法 - ウェブ関連技術調査 http://web.just4fun.biz/PHP/Ubuntu%E3%81%AEPHP%E7%92%B0%E5%A2%83%E3%81%ABGD%E3%83%A9%E3%82%A4%E3%83%96%E3%83%A9%E3%83%AA%E3%81%AE%E3%82%A4%E3%83%B3%E3%82%B9%E3%83%88%E3%83%BC%E3%83%AB%E3%81%99%E3%82%8B%E6%96%B9%E6%B3%95.html

ここのページを参考に

sudo apt-get install php5-gd

で入った。たぶんGDとphpから呼び出す設定が加わったようだ

インストール後

$ php5 -i | grep -Ei '^(gd|imagic|gmagic)' | grep enabled
GD Support => enabled

と出る

その他リンク

PHPの拡張モジュールGDが動くまでの試行錯誤 - Qiita http://qiita.com/nusa/items/8a71dcc630e7d7118f5b


トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2016-01-21 (木) 09:13:45 (1184d)